keystone - Spectrum/TimeWarner/Verizon Business circuits out for a VERY wide service area – Incident details

All systems operational

Spectrum/TimeWarner/Verizon Business circuits out for a VERY wide service area

Resolved
Partial outage
Started over 2 years agoLasted about 19 hours

Affected

ISP

Partial outage from 5:44 PM to 12:42 PM

Spectrum

Partial outage from 5:44 PM to 12:42 PM

Updates
  • Resolved
    Resolved

    We have seen the majority of Spectrum links come back online. If you are still experiencing issues, today, please reach out to our service desk or your account manager.

  • Update
    Update

    We are seeing both cable and fiber circuits coming back up over most of our service area. We will continue monitoring through the remainder of the business day.

  • Update
    Update

    We have confirmed that Spectrum is aware of the outage. At this time, there is no ETA for a full recovery of services, though we have seen some of our customers' circuits come back online. We will continue to update as we get information.

  • Investigating
    Investigating

    We are receiving reports of a very wide service outage related to Spectrum/TimeWarner/Verizon Business and any underlying carriers that use their back-bone. We have not other information at this time, but have reached out to out reps for an outage ETA and more info. We will post regular updates until the outage has cleared.