keystone - Microsoft 365 Service health status – Incident details

All systems operational

Microsoft 365 Service health status

Resolved
Degraded performance
Started almost 5 years agoLasted about 6 hours

Affected

Core Services

Degraded performance from 4:55 PM to 11:20 PM

Microsoft 365

Degraded performance from 4:55 PM to 11:20 PM

Updates
  • Resolved
    UTC
    Resolved

    The incident has been resolved

  • Update
    UTC
    Update

    Microsoft is continuing to perform our mitigation actions and have begun seeing an improvement in service availability. More details can be found in the admin center under MO297147.

  • Investigating
    UTC
    Investigating

    Title: Some users may experience intermittent failures when accessing various My Apps functionality User Impact: Users may experience intermittent failures when accessing various My Apps functionality. More info: Users who attempt to load My Apps functionality may experience failures or see errors when attempting the following functions: -Single Sign on (SSO) applications including Microsoft 365 applications -Registering for multifactor authentication -Self-service password reset -Performing self-service management of groups -Accepting terms of use agreements As a workaround, users may be able to refresh to alleviate the impact. Current status: We've determined that a recent change was resulting in impact. Scope of impact: Impact is specific to users who are routed through the affected infrastructure, primarily in the central region of North America. Please see https://status.office.com/ for more granular updates from Microsoft