keystone - KeyStone Voice Call Quality Issues – Incident details

All systems operational

KeyStone Voice Call Quality Issues

Resolved
Degraded performance
Started about 1 year agoLasted 1 day

Affected

3rd Party Platforms

Degraded performance from 6:00 PM to 11:57 AM

FluentStream Voice

Degraded performance from 6:00 PM to 11:57 AM

Updates
  • Resolved
    Resolved

    Our provider has let us know that they have resolved the issue within the Lumen network. If you are still experiencing issues, please call and let us know. Thank you!

  • Update
    Update

    We have received information from our Provider: "Earlier this morning, we became aware of an issue within the Lumen network that impacted audio on inbound and outbound calls. As of 1:40PM EST, Lumen was removed from our outbound routing to alleviate calling issues and take an alternative route. Inbound calling is still affected by this. At this time, we are working with Lumen and escalating the Lumen ticket to higher level management to obtain a faster resolution. Thank you for your patience!" We'll update as soon as we get more info from our provider. Outbound calling should no longer be affected.

  • Investigating
    Investigating

    We have received notification from a subset of customers that they are experiencing quality issues with their voice services. We are working now to assess the spread of the reported issues and are working with the provider to find a cause. If you are currently experiencing voice issues, please let us know.