keystone - Google Global Outage – Incident details

All systems operational

Google Global Outage

Resolved
Partial outage
Started 11 months agoLasted 29 minutes

Affected

Core Services

Partial outage from 7:17 PM to 7:45 PM

Googe Workspace

Partial outage from 7:17 PM to 7:45 PM

Updates
  • Resolved
    Resolved

    Google has posted full resolution of this issue.

  • Update
    Update

    Google has confirmed resolution except for Google Meet

  • Investigating
    Investigating

    We are investigating a global outage impacting a number of google services including Gmail, Google Calendar, Drive, Docs, Meet, etc. We are monitoring the situation and will update when Google provides an update https://www.google.com/appsstatus/dashboard/