Started about 1 year agoJuly 10, 2025Lasted about 1 hourJuly 10, 20255:467:05 PMUTC
Affected
ISP
Partial outage from 5:46 PM to 7:05 PM
Spectrum
Partial outage from 5:46 PM to 7:05 PM
Updates
Resolved
UTC
Resolved
UTC
We are seeing this resolved from our end. Please let us know if you are still having any issues.
Investigating
UTC
Investigating
UTC
Spectrum Cable is experiencing an outage in the Cleveland/Bradley County TN.
This may be power or weather related. Spectrum is aware and will provide updates.