keystone - Delay in receiving tickets submitted via e-mail – Incident details

All systems operational

Delay in receiving tickets submitted via e-mail

Resolved
Partial outage
Started 5 months agoLasted about 4 hours

Affected

KeyStone Service Desk

Partial outage from 7:30 PM to 11:44 PM

Inbound Email Processing

Partial outage from 7:30 PM to 11:44 PM

Updates
  • Resolved
    Resolved

    The incoming email issue has been resolved.

  • Investigating
    Investigating

    We are currently experiencing a delay in receiving tickets submitted via email. If you need help immediately, please contact us by phone or via Keystone Support Chat.